[Witty Title] '95 SJ413 rescue

Got an vehicle build underway? post up pictures and tell us all how its going!

Builds threads only please.
Rankine
Can I have a tow
Can I have a tow
Posts: 260
Joined: Sun Nov 23, 2014 1:38 pm
Location: Stirling, Scotland

Re: [Witty Title] '95 SJ413 rescue

Post by Rankine » Fri Feb 02, 2024 6:03 pm

Glad to see the rev counter working. It's all coming together!
SJ413 LWB Santana 33s, 94",

stimpy
Engaged 4wd low
Engaged 4wd low
Posts: 102
Joined: Mon Nov 14, 2016 10:03 pm

Re: [Witty Title] '95 SJ413 rescue

Post by stimpy » Sun Feb 04, 2024 12:01 pm

Great news on the tacho mate!! And love the analogy on "baby steps" !! :hahaha:

Tango91
Got muddy boots
Got muddy boots
Posts: 37
Joined: Sat Dec 30, 2023 1:44 am

Re: [Witty Title] '95 SJ413 rescue

Post by Tango91 » Mon Feb 05, 2024 12:31 am

Spent most of today hard at work on building that lean-to so I've somewhere to store the SJ, the SV, and all my tools.
Sally came out and looked at it earlier and said she thought it'd be finished by now, what was taking so long? :roll:

IMG_0588.jpeg

Baby steps, I've been working 6 days a week for a while :screwy:

After it stopped being acceptable to make power tool noises on a Sunday I had a play with the SJ. Got the gearshift tower properly sealed back onto the top of the gearbox with RTV and some nice stainless hardware (I love stainless hardware).

Drilled a small hole in the passenger floorpan to let all the water out, it's coming in through from the bed past the "bulkhead" somewhere. If it still had carpets they'd be ruined! I'm sure there's an idiom or analogy somewhere that fits but I can't think of it right now. :hmm:

After cooking dinner (did you know you can air fry the hot dogs (200C, 4 minutes), the onions (coarsely sliced, tossed in salt and olive oil, 5 minutes) AND the buns (2 minutes)?) I found myself at a loss for something to do so thought I'd go looking in the SJ for some more bodges.

The indicators have never worked properly, the stalk is stiff in one direction and likes to self-cancel with a crack, and often without invitation. I think it was noted on an MOT at some point as well.

I pulled off the horn button to have a gander and see what Ol' mate Dave's been about.

IMG_0590.jpeg

I just assumed he didn't own a soldering iron, so this was a surprise. Also looks like he's tried to pry the contacter ring out with a screwdriver instead of unscrewing it from behind as it's bent up in a few places and the plastic ring around it is all mashed up. :tosser:

We need to go deeper, though.

IMG_0591.jpeg

Jesus christ. :roll:

That bit of metal, which as far as I can make out is a flattened cheapo angle bracket you might buy from Wilko's on your way to buy some Pick-n-Mix (RIP) was held in with a small screw threaded into a convenient hole in the plastic behind, and a long machine screw and nut through to the back of the assembly. Very loose and rattly.

IMG_0592.jpeg

For some insane reason Dave's also screwed this white rocker part that probably allows the indicators to self-cancel (?) to the black bit that moves with the stalk. Incredibly, the ball bearing used for the detent was still where it was supposed to be, although I subsequently managed to shoot it across the room several times.

IMG_0594.jpeg

The contact ring for the horn button is all mashed up as well, irritatingly, although the wiper/contact seems to be missing from the assembly so I guess that's something of a moot point. :er:


I pulled Dave's handiwork off and made a pleasant if slightly surprising discovery; the wiper switch has never been able to go past the 'low' setting. I chalked that up to a broken switch or something but the actual problem was that screw Dave put into the convenient hole, it was blocking the sliding shuttle part of the mechanism underneath from moving all the way across, as you might be able to make out in these photos

IMG_0595.jpeg
IMG_0596.jpeg

I looked at the prices for a complete replacement online, which was enough to cure me of that notion, and set about making something to repair this onen and prevent the detent ball shooting out under spring pressure when moved.

Alright, i could drop ~£55 for a replacement of unknown quality, but they all seem to have the indicator stalk on the left, which I don't want, I firmly believe all RHD cars should have the indicator/lights stalk on the right.

I dug out some aluminium angle from the scraps box to have a go with. I haven't got the luxury of using my little milling machine as all my hobby machining stuff is in purgatory in the conservatory, which is an excellent album title, so instead it was a vise, hacksaw and files. I quite enjoyed getting back to basics to be honest.

IMG_0597.jpeg

My first attempt. I was hoping to use screws through the side there into the plastic underneath to secure it, but upon some exploratory drilling I found that this area was occupied by the shuttle for the wiper switch so that was a no-go.

IMG_0601.jpeg

Attempt 2 uses two of the 4 mounting holes at the base of the plastic moulding. Luckily I still have access to my lathe so i knocked up some aluminium tubes to support the aluminium angle at the appropriate height to brush but not drag on the moving bit of the indicator stalk/detent bit. It works just a little bit smoother than Dave's attempt if i'm honest.

I crimped an eye onto that blue wire and screwed it into the aluminium for luck, I assume it's some part of the now-defunct horn button assembly but at least it's not flapping about now.

I threw the lot back into the car and... nothing. Two very baffled minutes later I remembered that I hadn't plugged in either of the connectors :er:

I'm pleased to report that I seem to have gained a smooth action on the indicator stalk, they seem to self-cancel properly (and quietly) as far as I can tell with the car standing still, and as a bonus I now have 'high' speed on the wipers, which seems to be writing a cheque that the poor wiper motor can't quite cash. I guess it struggles slightly faster?

Anyway, time to go to bed.

ad862b5d-7e0b-4b91-9c95-8ec662aad948.jpg

Cat.

Rankine
Can I have a tow
Can I have a tow
Posts: 260
Joined: Sun Nov 23, 2014 1:38 pm
Location: Stirling, Scotland

Re: [Witty Title] '95 SJ413 rescue

Post by Rankine » Mon Feb 05, 2024 7:28 am

Some quality repairs there man.
SJ413 LWB Santana 33s, 94",

User avatar
tomcat
Engaged 4wd low
Engaged 4wd low
Posts: 205
Joined: Wed May 04, 2022 6:59 pm

Re: [Witty Title] '95 SJ413 rescue

Post by tomcat » Mon Feb 05, 2024 8:47 am

Such detail and patience sorting out 'Dave's' contributions as a PO.

Tango91
Got muddy boots
Got muddy boots
Posts: 37
Joined: Sat Dec 30, 2023 1:44 am

Re: [Witty Title] '95 SJ413 rescue

Post by Tango91 » Mon Feb 05, 2024 8:32 pm

That new exhaust finally tipped up today while I was at work, so when I got home I pulled the old exhaust off.

If you squint you can just about see the difference, (bad photo I know)

IMG_0610.jpeg

I did make some Dave-related discoveries along the way, there is truly no part of this car he hasn't touched. I honestly believe that if I were to take a can opener to the oil pan there'd be a few scotchlocks, mismatched wire and tek screws rattling about in there. :roll:

The manifold heat shields were held on with this fine assortment of fastenings, including 2 varieties of tek screw and random M6 studs and bolts.

IMG_0608.jpeg

The manifold itself...

IMG_0609.jpeg

We'll, uh, pretend we didn't see that. :smokin:


I couldn't fit the new shiny exhaust unfortunately, as I find myself needing 54.85% more fibre gasket to seal to the manifold (no wonder there was a blow there :roll: )

IMG_0611.jpeg

I've ordered 2 of those and 4 rubber hangers as Dave's been teething on the ones on there. I'll probably need to make some metal spacer sleeves to go inside but we'll see what's needed when they show up.


On the punishment bench today is both of the cheapie 1/4" ratchets I own, both of them jumped teeth while I was undoing the header clamp bolts and made me skin my knuckles and say naughty words.

IMG_0617.jpeg

Pulling them apart doesn't reveal much but I'm buggered if I'm letting these things draw blood from me again. I've ordered some nice Halfords Advanced replacement ones that aren't the concentric type, we'll see.

Tango91
Got muddy boots
Got muddy boots
Posts: 37
Joined: Sat Dec 30, 2023 1:44 am

Re: [Witty Title] '95 SJ413 rescue

Post by Tango91 » Sat Feb 17, 2024 12:07 pm

Hey, what's better than one rusty POS?

IMG_0739.jpeg

Let this be a lesson for everyine: Don't ever sell cars to family. :| I was only supposed to give the Disco a service this weekend but in the nearly a year since its rebuild and MOT, it's eaten two front wheel bearings and ABS sensors, both front lower shock mounts, the ball joint on the steering box arm, the front main crank seal, the crank pulley dampener (£££), and developed several new large rust holes which I am choosing to ignore.

and thanks to that crank seal, all the oil has decided to go on holiday from here

A5A4F13F-5B6B-4F01-8053-19424B3356FE.jpg

To here

9E0D27B9-921C-46CD-9D54-83FAD3C9AF73.jpg

Via here

D845205A-E361-45BB-8180-7B2203945EEB.jpg

On the upside, I guess it isn't rusting quite so fast as the entire underside is covered in oil :hmm:

As is TD5 tradition, the injector wiring loom, which I also replaced a year ago, is full of oil from the connector at the valve cover right up to the plug on the ECU. Again. And it's running on 4.5 cylinders.

It's been a nice reminder of why I got rid of the bloody thing and bought the nice simple Suzuki :hahaha:

stimpy
Engaged 4wd low
Engaged 4wd low
Posts: 102
Joined: Mon Nov 14, 2016 10:03 pm

Re: [Witty Title] '95 SJ413 rescue

Post by stimpy » Sat Mar 09, 2024 7:24 pm

Hahahaha... Them Discos are never easy!!!

Tango91
Got muddy boots
Got muddy boots
Posts: 37
Joined: Sat Dec 30, 2023 1:44 am

Re: [Witty Title] '95 SJ413 rescue

Post by Tango91 » Sat Mar 09, 2024 9:01 pm

Dear Diary,

I know I've been neglecting you, but life's been a whole thing lately.

Building myself a lean-to has been occupying all my very limited free time, The last few weeks I've been working every hour god sends and a few more to boot.

IMG_0759.jpeg

Finally the SJ got moved inside.

IMG_0941.jpeg

Eventually this'll have a wall at the back, workbenches, storage, power, doors and a proper floor, but today it was raining again so I decided sod the DIY and actually managed to set aside a few hours to work on the Suzuki.


I thought I'd have a gamble on a pot of JB Weld Extreme Heat and slathered that all over the cracked exhaust manifold. I figure if it doesn't work then hey, it was less than a tenner. :roll: You won't see this under the heat shields anyway, so it'll be our secret. :brows:

IMG_1033.jpeg


I've had the new fuel pump sat in a box for weeks and thought I might finally fit it.

Removing the tank again was not quite as straightforward as I'd have liked (you never ever have to drop an empty tank, they're always mostly full, and the filler neck is halfway up).

The old pump proved a proper bastard to remove, 6/6 stripped then snapped machine screws :argh:

IMG_1035.jpeg
IMG_1039.jpeg

The old pump didn't come out looking too bad, no evidence of the pickup being blocked.

IMG_1036.jpeg

The inside of the tank had a little sediment kicking about but no real rust or anything too scary, which is impressive if you remember how the fuel/gravy that came out of this thing at the start looked.

IMG_1038.jpeg

I drilled the snapped machine screws out to 5mm then tapped for M6 stainless hardware. Shout out to these Dewalt Cobalt Extreme drill bits with the pilot point, once you've drilled a small pilot hole they follow it perfectly and go through the old hardware like butter. Totally worth the price premium over standard twist drills IMHO and they also seem to last ages.
51738047.jpg
IMG_1041.jpeg

That looks better, don't you agree? I love stainless hardware. I paid a little extra for the "OEM" "Denso" pump, whether or not it's actually any difference from the pattern part remains to be seen but eh.

I blew both feed and return fuel lines out with air from both the throttle body and tank ends to make sure there wasn't a blockage, and they seemed pretty easy to blow through.

I remounted and refilled the tank, cycled the ignition a few times to prime the system, then pulled the return line off the fuel pressure regulator at the throttle body, and routed a bit of hose into a litre bottle.

IMG_1045.jpeg

The engine started right up and I'm pleased to report that this much ended up in the bottle after about 10 seconds of running. If you remember back I previously didn't have anything coming out the back of the fuel pressure regulator at all so I hope that this cures the fuel/running problem and this expensive firing of the parts cannon was succesful.

To test it around the block without making the neigbours lynch me I though I should probably fit the shiny new exhaust that's been sat in a pile for the past month.

I haven't got any photos but I got the front section mounted with new rubbers and a crush gasket. I had to make one of the mounts out of some stainless sheet to mimic the factory one, but I got there in the end. I had to call it a night there but I hope to have a few hours more tomorrow.

I've never had my own workshop before, so even laying on uneven slabs and gravel with no doors was pretty cool (and dry). I also just got offered a new job that is better in every measurable way than the one I'm leaving, so from April I should have waaaaaay more free time to work on this damn thing, assuming I can keep safely ignoring the Mrs. :brows:

Cheers! :D

Tango91
Got muddy boots
Got muddy boots
Posts: 37
Joined: Sat Dec 30, 2023 1:44 am

Re: [Witty Title] '95 SJ413 rescue

Post by Tango91 » Sun Mar 10, 2024 9:58 pm

I finished putting on the first half of the exhaust today.

Ol' mate Dave had the old exhaust clamped together with some m8 bolts that were very loosey goosey. The manifold flange is threaded for a 10mm bolt, but I believe it's a fine pitch? In any case the coarse pitch bolts I have would start on the threads then bind up. I decided to drill the threads in the manifold flange out to a 10mm hole and use nuts on the top side instead.

The outside hole was no problem as you can get to it from above with a drill. The inner one is of course in behind the manifold so I had to attack it from underneath. However the bellhousing is in the way of getting a straight shot at the manifold flange so I had to cobble together this monstrosity from an impact bit holder and some stainless rod to get at it. It'll go in the box of tools that I had to make and will never be useful for anything again ever.

IMG_1050.jpeg

I fired the SJ up and let it warm up for a few minutes. I've got to say it sounds great, lovely and smooth with that new fuel pump, even with inly half an exhaust system. However, since I've had it I've been sure I could hear a vacuum leak if you revved it from somewhere around the throttle body but never been able to trace it back to any of the vacuum hoses. Today I must have been extra liberal with the brake cleaner and managed to track it down to air being sucked in around this bolt clamping the throttle body to the manifold, which to me says a blown gasket.

IMG_1052.jpeg

I squirted a glob of thick oil on there and it made quite the funny noise as it sucked it into the engine.

Pulling the 4 bolts out and prying the throttle body up was made slightly more interesting by the fact that the coolant flows through this joint, and was at that moment still hot and under pressure, two things I'd not taken into account. But once the burning had stopped I could see why I'd got a vacuum leak at the gasket, I think this might have been a cornflakes box at one point, just a wet mushy mess.

IMG_1055.jpeg

I split the injector body off the throttle body as you could see if you looked down the bore that the gasket was torn and in one place protruding out into the bore, so better safe than sorry. This looks to be a proper gasket but it was still crispy and came out in several bits.

IMG_1062.jpeg

I haven't managed to find any pre-cut replacements for the gaskets online, so I've ordered a sheet of 0.8mm Flexoid gasket paper and unless someone can point me in the direction of a proper set I'll have to have a go at making my own.

I also took advantage of the access to pull out this bistly bit of gas hose that was supplying coolant to the throttle body

IMG_1061.jpeg

Just ordered a few metres of proper 8mm bore coolant hose so this'll get replaced along with a few other questionable bits in there in the near future.

Cheers!

Post Reply