Unknown Power Loss

Got an electrical gremlin? Ask the question here.
Post Reply
Aaron1963
Got muddy boots
Got muddy boots
Posts: 2
Joined: Wed May 08, 2019 11:57 am

Unknown Power Loss

Post by Aaron1963 » Wed May 08, 2019 12:04 pm

I was driving along the road in my 02 registered Jimny when the engine just died. I managed to drift to the side of the road and tried to restart and athough the engine turned over, it would not start. I assumed that I had run out of fuel despite the guage showing that I have quarter of a tank, but called the garage and they recovered it and I put more fuel in - still will not start. The mechanic had a look at it and said there was no fuel coming through so it was probably an issue with the fuel pump and they would fix it.

However, the next day after the mechanic tested the car it transpired that there was no spark at the plugs either and although everything else was working, the car would not pump fuel or make a spark at the plugs.

My mechanic is not over-experienced with this issue and is confused at what is happening and has assumed that the issue is the ICU but thats as far as we have got so far.

Has anyone had this problem, or can anyone help resolve it?

Any information would be much appreciated, thank you in advance.

User avatar
Anton
I spend far too much time on here
I spend far too much time on here
Posts: 3674
Joined: Tue Jan 12, 2010 12:12 pm
Location: London

Re: Unknown Power Loss

Post by Anton » Wed May 08, 2019 9:09 pm

Something similar happened to me with a Toyota Yaris, turned out the key transponder for the immobiliser was bad, so the ECU shut down the fuel pump.

Shouldn't happen when you're driving, but I don't know much about immobilisers. Get an ODB2 reader, plug it into your ECU, read the fault codes. A couple of guys on here will be able to help you further when you've got the codes. Google may even be able to tell you what the problem is at that point.
1985 SJ413VX (SJ50V) with SPOA, rear disc brakes, 31x10.5R15 Kaiman Malatesta tyres, an MOT and a lot left to do!

My: Build thread To-do list Pay and Play map

User avatar
Ju
Can I have a tow
Can I have a tow
Posts: 308
Joined: Tue Nov 04, 2014 8:19 pm
Location: Swindon, Wilts

Re: Unknown Power Loss

Post by Ju » Wed May 08, 2019 9:49 pm

The immobiliser should not come into play when the engine is running. It may be worth checking the wiring as you may have wire damage or filled a relay or fuse box up with crap.
Image

Aaron1963
Got muddy boots
Got muddy boots
Posts: 2
Joined: Wed May 08, 2019 11:57 am

Re: Unknown Power Loss

Post by Aaron1963 » Wed May 08, 2019 11:07 pm

Well we dont go off road in it, but there was a birds nest to the left of the engine when we first opened the bonnet when it broke down.

My mechanic cannot find a wiring diagram, so has anyone got any ideas where I can start? Any relay that would affect both the fuel pump and spark plugs?

User avatar
Anton
I spend far too much time on here
I spend far too much time on here
Posts: 3674
Joined: Tue Jan 12, 2010 12:12 pm
Location: London

Re: Unknown Power Loss

Post by Anton » Thu May 09, 2019 3:01 pm

Aaron1963 wrote:
Wed May 08, 2019 11:07 pm
so has anyone got any ideas where I can start?
Yes. An OBD2 scanner. They're £10 or so. Or a bluetooth/wifi one (if you're ok using a smartphone/tablet) for under £5.
1985 SJ413VX (SJ50V) with SPOA, rear disc brakes, 31x10.5R15 Kaiman Malatesta tyres, an MOT and a lot left to do!

My: Build thread To-do list Pay and Play map

Post Reply