4wd light not showing

Got an electrical gremlin? Ask the question here.
Post Reply
Austin1999
Got muddy boots
Got muddy boots
Posts: 16
Joined: Sat Mar 31, 2018 11:16 am

4wd light not showing

Post by Austin1999 » Wed Jan 30, 2019 9:36 pm

My samurais 4wd light is broken, i have replaced the bulb in the dash, and replaced the switch in the transfer box but the 4wd light on the dashboard still doesnt come on when it is engaged.
Any ideas?
Thankyou

User avatar
ROBBIE
I spend far too much time on here
I spend far too much time on here
Posts: 4347
Joined: Tue Sep 09, 2008 6:32 pm
Location: Dorset or stuck

Re: 4wd light not showing

Post by ROBBIE » Wed Jan 30, 2019 9:58 pm

Broken wire somewhere, try and see if it’s been caught up somewhere or been pinched and squashed
Sid James gone but never forgotten
Jimny 1.6 not as good as an SJ but still good

Austin1999
Got muddy boots
Got muddy boots
Posts: 16
Joined: Sat Mar 31, 2018 11:16 am

Re: 4wd light not showing

Post by Austin1999 » Thu Jan 31, 2019 9:47 pm

Thankyou, any idea where the wires run?

User avatar
ROBBIE
I spend far too much time on here
I spend far too much time on here
Posts: 4347
Joined: Tue Sep 09, 2008 6:32 pm
Location: Dorset or stuck

Re: 4wd light not showing

Post by ROBBIE » Thu Jan 31, 2019 10:41 pm

Sorry no idea. From what I remember there isn’t much before they enter the rest of the wires to the rear lights.
Stupid question, have you checked the fuse box?
Sid James gone but never forgotten
Jimny 1.6 not as good as an SJ but still good

Austin1999
Got muddy boots
Got muddy boots
Posts: 16
Joined: Sat Mar 31, 2018 11:16 am

Re: 4wd light not showing

Post by Austin1999 » Fri Feb 01, 2019 6:47 pm

Okay thanks, yeah Iv checked all the fuses and none are blown

User avatar
Darrell
Suzuki, will you marry me?
Suzuki, will you marry me?
Posts: 2989
Joined: Wed Feb 23, 2011 7:54 pm
Location: south oxfordshire
Contact:

Re: 4wd light not showing

Post by Darrell » Fri Feb 01, 2019 7:11 pm

Circuit is very simple. The dash light has 12v positive to it with ignition on. The switch just supplies the ground/earth, so at the switch with ignition on you should read 12v across the two wires. Ground the positive and see if the light comes on, we''ll go from there.
2005-GV 1600se, "Hell" What do I know!

Austin1999
Got muddy boots
Got muddy boots
Posts: 16
Joined: Sat Mar 31, 2018 11:16 am

Re: 4wd light not showing

Post by Austin1999 » Fri Feb 01, 2019 9:04 pm

Thanks ill try that soon

User avatar
ScottieJ
The Boss
The Boss
Posts: 11211
Joined: Tue Apr 15, 2008 12:13 pm
Location: Chippenham, wiltshire

Re: 4wd light not showing

Post by ScottieJ » Sun Feb 03, 2019 10:43 pm

Has it ever worked? if not the detent ball that operates the switch might be missing.
Zuki Build

Steady as she goes!

Post Reply