Unable to Engage 4 Lock or 4L

All tech relating to the Suzuki Vitara that won't relate to any other models, Front IFS etc.
Post Reply
RussH
Got muddy boots
Got muddy boots
Posts: 3
Joined: Thu Oct 14, 2021 10:40 am

Unable to Engage 4 Lock or 4L

Post by RussH » Thu Oct 14, 2021 10:51 am

Hello, I've just acquired a 2007 Grand Vitara. It's been really well looked after and drives great. However. I can't get it to engage 4 Lock or 4 Low.
The selector moves just fine, but no lights on the selector or the dash. I've tried doing it stationary, moving slowly in neutral or in gear.
I've checked all the fuses.
I doubt the previous owner ever tried to engage the centre diff. or put it in 4L.
I've tried searching the forum and Google but haven't got anywhere. I haven't even found any information on how it actually operates. Is it an electrical motor, vacuum operated?
Any pointers gratefully received. I'm pretty competent with this sort of stuff but have no knowledge of this system.

User avatar
donkeychomp
I spend far too much time on here
I spend far too much time on here
Posts: 3570
Joined: Thu Aug 18, 2011 3:49 pm
Location: Shepperton, Middx

Re: Unable to Engage 4 Lock or 4L

Post by donkeychomp » Thu Oct 14, 2021 9:16 pm

It may well be in four wheel drive but the bulb has blown on the dash. Have you checked to see if all the wheels are moving?
If it ticks over...leave it

RussH
Got muddy boots
Got muddy boots
Posts: 3
Joined: Thu Oct 14, 2021 10:40 am

Re: Unable to Engage 4 Lock or 4L

Post by RussH » Fri Oct 15, 2021 8:02 am

Thanks for the reply, it's got power to all 4 wheels.
But I can't get it to lock the centre diff. Or select low range.
No warning lights appear on the dash, either when you turn the ignition on or when you turn the selector knob.
It seems dead. The previous owner had been jump starting it so I'm guessing he may have tried the 4x4 control unit. I've found some info about how it operates so I'll start testing for volts at the control unit and actuation motor.
I tried connecting a scanner but it wouldn't communicate:-(

RussH
Got muddy boots
Got muddy boots
Posts: 3
Joined: Thu Oct 14, 2021 10:40 am

Re: Unable to Engage 4 Lock or 4L

Post by RussH » Fri Oct 15, 2021 5:30 pm

All sorted:-)

A mouse had been munching through the wiring harness.

Post Reply